Difference between revisions of "Creating a new project"

From CodeBlocks
Jump to: navigation, search
Line 95: Line 95:
 
See [[the build process of Code::Blocks]] for what occurs behind the scenes during a compile.
 
See [[the build process of Code::Blocks]] for what occurs behind the scenes during a compile.
 
==Modifying build options==
 
==Modifying build options==
 +
[[File:TargetSelect.png|right]]
 +
Build targets have come up several times so far. Changing between the two default generated ones - '''Debug''' and '''Release''' - can simply be done through the drop-down list on the '''Compiler Toolbar'''. Each of these targets has the ability to be a different type (for example: static library; console application), contain a different set of source files, custom variables different build flags (for example: debug symbols ''-p''; size optimization ''-Os''; link time optimization ''-flto''), and several other options.
 +
 +
Open ''Project->Properties...'' to access the main properties of the active project, '''HelloWorld'''. Most of the settings on the first tab, '''Project settings''', are rarely changed. '''Title:''' allows the name of the project to be changed. If '''Platforms:''' is changed to something other than its default '''All''', Code:Blocks will only allow the project to build on the selected targets. This is useful if, for example, the source code contains Windows API, and would therefore be invalid anywhere but Windows (or any other operating system specific situations). The '''Makefile:''' options are used only if the project should use a makefile instead of Code::Blocks' internal build system (see [[Code::Blocks and Makefiles]] for further details).
 +
[[File:TargetOptions.png|right]]
 +
Switch to the '''Build targets''' tab. Click '''Add''' to create a new build target and name it '''Release Small'''. The highlight in the left hand column should automatically switch to the new target (if not, click on it to change the focus). As the default setting for '''Type:''' -  "GUI application" - is incorrect for the '''HelloWorld''' program, change it to "Console application" via the drop-down list. The output filename '''HelloWorld.exe''' is fine except in that it will cause the executable to be output in the main directory. Replace it with '''bin\ReleaseSmall\HelloWorld.exe''' (Windows) or '''bin/ReleaseSmall/HelloWorld.exe''' (Linux) to change the directory (it is a relative path from the root of the project).

Revision as of 03:19, 17 August 2011

This is a work in progress, and may be missing key details.

The project wizard

ProjectWizard.png

Launch the Project Wizard through File->New->Project... to start a new project. Here there are many pre-configured templates for various types of projects, including the option to create custom templates. Select Console application, as this is the most common for general purposes, an click Go.

The console application wizard will appear next. Continue through the menus, selecting C++ when prompted for a language. In the next screen, give the project a name and type or select a destination folder. As seen below, Code::Blocks will generate the remaining entries from these two.

ConsoleApplication.png

SelectSource.png
Finally, the wizard will ask if this project should use the default compiler (normally GCC) and the two default builds: Debug and Release. All of these settings are fine. Press finish and and the project will be generated. The main window will turn gray, but that is not a problem, the source file needs only to be opened. In the Projects tab of the Management pane on the left expand the folders and double click on the source file main.cpp to open it in the editor. This file contains the following standard code.

main.cpp

  1. #include <iostream>
  2.  
  3. using namespace std;
  4.  
  5. int main()
  6. {
  7.     cout << "Hello world!" << endl;
  8.     return 0;
  9. }

Changing file composition

A single source file is of little uses in programs of any useful complexity. In order to handle this, Code::Blocks has several very simple methods of adding additional files to the project.

Adding a blank file

In this example, we will be splitting the function

main.cpp

  1.     cout << "Hello world!" << endl;

into a separate file. To add the new file to the project, bring up the file template wizard through either File->New->File... or Main Toolbar->New file (button)->File...

NewFile.png

Hello.cpp.png

Select C/C++ source and click Go. Continue through the following dialogs very much like the original project creation, selecting C++ when prompted for a language. On the final page, you will be presented with several options. The first box will determine the new filename and location (as noted, the full path is required). You may optionally use the ... button to bring up a file browser window to save the file's location. Checking Add file to active project will store the filename in the Sources folder of the Projects tab of the Management panel. Checking any of the build targets will alert Code::Blocks that the file should be compiled and linked into the selected target(s). This can be useful if, for example, the file contains debug specific code, as it will allow the inclusion (or exclusion) from the a the appropriate build target. In this example, however, the hello function is of key importance, and is required in each target, so select all the boxes and click Finish to generate the file.

The newly created file should open automatically; if it does not, open it by double clicking on its file in the Projects tab of the Management panel. Now add in code for the function main.cpp will call.

hello.cpp

  1. #include <iostream>
  2.  
  3. using namespace std;
  4.  
  5. void hello()
  6. {
  7.     cout << "Hello world!" << endl;
  8. }

Adding a pre-existing file

Now that the hello() function is in a separate file, the function must be declared for main.cpp to use it. Launch a plain text editor (for example Notepad or Gedit), and add the following code.

hello.h

  1. #ifndef HELLO_H_INCLUDED
  2. #define HELLO_H_INCLUDED
  3.  
  4. void hello();
  5.  
  6. #endif // HELLO_H_INCLUDED
TargetBelonging.png

Save this file as a header (hello.h) in the same directory as the other source files in this project. Back in Code::Blocks, click Project->Add files... to open a file browser. Here you may select one or multiple files (using combinations of Ctrl and Shift). (The option Project->Add files recursively... will search through all the subdirectories in the given folder, selecting the relevant files for inclusion.) Select hello.h, and click Open to bring up a dialog requesting to which build targets the file(s) should belong. For this example, select both targets.

Note: if the current project has only one build target, this dialog will be skipped.

Returning to the main source (main.cpp) include the header file and replace the cout function to match the new setup of the project.

main.cpp

  1. #include "hello.h"
  2.  
  3. int main()
  4. {
  5.     hello();
  6.     return 0;
  7. }

Press Ctrl-F9, Build->Build, or Compiler Toolbar->Build (button - the gear) to compile the project. If the following output is generated in the build log (in the bottom panel) then all steps were followed correctly.

-------------- Build: Debug in HelloWorld ---------------

Compiling: main.cpp
Compiling: hello.cpp
Linking console executable: bin\Debug\HelloWorld.exe
Output size is 923.25 KB
Process terminated with status 0 (0 minutes, 0 seconds)
0 errors, 0 warnings (0 minutes, 0 seconds)

The executable may now be run by either clicking the Run button or hitting Ctrl-F10.

Note: the option F9 (for build and run) combines these commands, and may be more useful in some situations.

See the build process of Code::Blocks for what occurs behind the scenes during a compile.

Modifying build options

TargetSelect.png

Build targets have come up several times so far. Changing between the two default generated ones - Debug and Release - can simply be done through the drop-down list on the Compiler Toolbar. Each of these targets has the ability to be a different type (for example: static library; console application), contain a different set of source files, custom variables different build flags (for example: debug symbols -p; size optimization -Os; link time optimization -flto), and several other options.

Open Project->Properties... to access the main properties of the active project, HelloWorld. Most of the settings on the first tab, Project settings, are rarely changed. Title: allows the name of the project to be changed. If Platforms: is changed to something other than its default All, Code:Blocks will only allow the project to build on the selected targets. This is useful if, for example, the source code contains Windows API, and would therefore be invalid anywhere but Windows (or any other operating system specific situations). The Makefile: options are used only if the project should use a makefile instead of Code::Blocks' internal build system (see Code::Blocks and Makefiles for further details).

TargetOptions.png

Switch to the Build targets tab. Click Add to create a new build target and name it Release Small. The highlight in the left hand column should automatically switch to the new target (if not, click on it to change the focus). As the default setting for Type: - "GUI application" - is incorrect for the HelloWorld program, change it to "Console application" via the drop-down list. The output filename HelloWorld.exe is fine except in that it will cause the executable to be output in the main directory. Replace it with bin\ReleaseSmall\HelloWorld.exe (Windows) or bin/ReleaseSmall/HelloWorld.exe (Linux) to change the directory (it is a relative path from the root of the project).