Difference between revisions of "KiCadBuildQuickRef"

From CodeBlocks
Jump to: navigation, search
(Patch CMake files to use Monolithic wxWidgets)
Line 40: Line 40:
 
====Install Code::Blocks====
 
====Install Code::Blocks====
 
====Patch CMake files to use Monolithic wxWidgets ====
 
====Patch CMake files to use Monolithic wxWidgets ====
 +
In file kicad/CMakeLists.txt
 +
change the following line
 +
find_package(wxWidgets COMPONENTS gl html adv core net base QUIET)
 +
to this line below
 +
find_package(wxWidgets COMPONENTS mono gl QUIET)
 +
 
====Use CMake to build the KiCad makefiles.====
 
====Use CMake to build the KiCad makefiles.====
  
 
====Use Code::Blocks to build KiCad.====
 
====Use Code::Blocks to build KiCad.====

Revision as of 01:08, 30 May 2009

How-to build KiCad with Code::Blocks

by Tim Stahlhut (stahta01)

Requirements

- wxWidgets
- MinGW GCC
- zlib
- Boost C++
- CMake
- Code::Blocks

MinGW GCC Compiler steps

install "mingw".

Install zlib.

For more zlib info see http://gnuwin32.sourceforge.net/packages/zlib.htm.
Download Developer files for Zlib from http://gnuwin32.sourceforge.net/downlinks/zlib-lib-zip.php
Extract the files from zlib-1.2.3-lib.zip into your MinGW base folder.
Download Binaries files for Zlib from http://gnuwin32.sourceforge.net/downlinks/zlib-bin-zip.php
Extract the DLL from zlib-1.2.3-bin.zip into any folder that is in your path; like your MinGW bin folder.

Install Boost C++ Template Libraries (*.hpp files)

  • BoostWindowsQuickRef: A beginner's quick reference for setting up Boost with Code::Blocks in Windows

wxWidgets Steps

Build KiCad using CMake and Code::Blocks Steps

Install the KiCad source tree.

Install CMAKE

Download the installation binary for windows from http://www.cmake.org.
http://www.cmake.org/cmake/resources/software.html
http://www.cmake.org/files/v2.6/cmake-2.6.3-win32-x86.exe
Install that and choose to add cmake to your path during installation.
You will have to restart and command shells for the new path to take effect.
Verify that cmake is in your path by trying to run it from a command prompt.

Install Code::Blocks

Patch CMake files to use Monolithic wxWidgets

In file kicad/CMakeLists.txt change the following line find_package(wxWidgets COMPONENTS gl html adv core net base QUIET) to this line below find_package(wxWidgets COMPONENTS mono gl QUIET)

Use CMake to build the KiCad makefiles.

Use Code::Blocks to build KiCad.