Difference between revisions of "Talk:Compile Code::Blocks plugins based on a nightly"

From CodeBlocks
Jump to: navigation, search
(Created page with "When linking directly to a <tt>dll</tt> (with MinGW), the file extension is not required, so <tt>wxmsw28u_gcc_cb.dll</tt> can be simply <tt>wxmsw28u_gcc_cb</tt> and <tt>codeblock...")
 
(mingw gcc version should match)
Line 1: Line 1:
 
When linking directly to a <tt>dll</tt> (with MinGW), the file extension is not required, so <tt>wxmsw28u_gcc_cb.dll</tt> can be simply <tt>wxmsw28u_gcc_cb</tt> and <tt>codeblocks</tt> can remain the unchanged. [[User:Alpha|Alpha]] 03:26, 23 August 2012 (CEST)
 
When linking directly to a <tt>dll</tt> (with MinGW), the file extension is not required, so <tt>wxmsw28u_gcc_cb.dll</tt> can be simply <tt>wxmsw28u_gcc_cb</tt> and <tt>codeblocks</tt> can remain the unchanged. [[User:Alpha|Alpha]] 03:26, 23 August 2012 (CEST)
 +
 +
I think the mingw gcc version should match the version build nightlies, other wise, there may be some conflict with symbols or other things, currently our nightlies use tdm gcc 4.5.x. [[User:Ollydbg|Ollydbg]] 03:52, 23 August 2012 (CEST)

Revision as of 03:52, 23 August 2012

When linking directly to a dll (with MinGW), the file extension is not required, so wxmsw28u_gcc_cb.dll can be simply wxmsw28u_gcc_cb and codeblocks can remain the unchanged. Alpha 03:26, 23 August 2012 (CEST)

I think the mingw gcc version should match the version build nightlies, other wise, there may be some conflict with symbols or other things, currently our nightlies use tdm gcc 4.5.x. Ollydbg 03:52, 23 August 2012 (CEST)